Clear all

[Solved] Unable to update firmware  

New Member
Unable to update firmware

Hello. My new Mini+ kit came with 4.3.1 firmware and I can't get it to update to 4.3.2.

I have downloaded the update to the driver I received (which I use also to upload gcodes to the printer, and it works fine) and removed the older one from it, and the printer keeps ignoring it. I tried restarting a few times. I have checked the settings and have set it to "update after restart", but it still won't help.

I would appreciate any help, thanks.


Posted : 13/09/2021 5:53 pm
Famed Member

Not sure I understand the procedure you describe but the correct way to upgrade Mini firmware is described here:

TL;DR: Copy the downloaded .bbf file to the root of a USB stick, stick it into the mini, then reboot.

Posted : 13/09/2021 10:48 pm
New Member
Topic starter answered:
That's what I did, and more

Yes that's exactly what I did, I also tried playing with the updating settings in the printer.

The printer simply ignores the update.

Posted : 14/09/2021 9:24 pm
Honorable Member

You know that file you downloaded needs to be unpacked (un-zipped) first, right?

[Mini+] [MK3S+BEAR]

Posted : 15/09/2021 7:34 am
New Member
Firmware 4.3.2 Successfully installed

Fischex - I had the exact same problem.... I got my new mini+ with 4.3.1 installed on it. My mini+ was actually giving me an error #12610 (saying that the firmware/printer versions don match and to go and make sure I had the correct firmware for my printer). Confusing! So I decided to try and flash the system backward to 4.3.0, see if that worked, and then climb back to to 4.3.1, and then 4.3.2.  I did this and it seemed to have solved my problem:

1. One thing I made sure I did, was I reformatted my USB stick again, and made the "Allocated Unit Size" 2048 bytes (instead of 4096 bytes - which is what I think was set with the USB stick that came with the mini+).

2. Next, I downloaded the .BBF .zip file, then I clicked to "open" .zip file. (I did all of this from the bottom bar in my web browser)

3. Next, I dragged and dropped the file to my desktop

4. Next, I opened file explorer up

5. Next, I dragged and dropped the newly downloaded .BBF file onto the USB drive (as it is listed in the left hand portion of the file explorer window).

6. Then, I selected to eject the drive

7. I plugged the USB into the mini+, hit restart button, and when the first PRUSA screen comes up, push the button wheel, and the flash process was successful for each version I did (going downward to 4.3.0, then back upward to 4.3.1, and then upward again to 4.3.2).

Let me know if this works!


Posted : 17/09/2021 1:42 am
Chris Barnes
Eminent Member
RE: Unable to update firmware

I ran into this problem as well.  If anyone is still attempting to upgrade I used a few extra steps in order to get mine to work.  For each step I had to reformat the drive with "Allocated Unit Size" 2048 bytes.

First I downgraded to 4.3.0 with freshly formatted 1GB USB drive.  "prusa3d_fw_4_3_0_MINI.bbf"

Next I upgraded to 4.4.0 with the same now re-formatted drive.  This drive had the bootloader and the new firmware files on it.  "mini_release_boot_4.4.0+4180.bbf" and "mini_release_boot_update_pre_4.4_4.4.0+4180.bbf".

This step took some time to upgrade the bootloader and then on self restart failed to load the new firmware.  I tried several time with no luck.  I realized I should try to reformat the drive again and place the same two files on it.

It worked with the new bootloader and the new 4.4.0 firmware.

Posted : 29/11/2022 4:36 pm
New Member
RE: Unable to update firmware

I saw this tip elsewhere on the forums.

If you find it will not read the file, preset the reset button and immediately click the selector dial twice.

I was about to say bad words before realizing this option existed!

Up and running now myself.



Posted : 30/11/2022 10:27 pm
New Member

Having two .bbf files in the 4.4.1 download, both with obscure names, confused me. I did finally figure out which file to use and to update successfully, but this process could have been made a LOT clearer. Prusa folks: please don't assume that everyone is up-to-date on version evolution and names and other minutiae. Assume that the user is just got their printer out of the closet after a year and is not a veteran of a thousand firmware updates. 😣 

This post was modified 2 months ago by Sherman8tor
Posted : 22/10/2023 11:04 pm
RE: Unable to update firmware

I am stuck here also. Following what seems like the solution that worked for @chris-barnes.

Reset my Mini+ to factory. which set the firmware to 4.3.1.

Downloaded 4.3.2, loaded on USB. The bootloader detected the new firmware and installed properly.
Downloaded 4.3.3, loaded on USB. The bootloader detected the new firmware and installed properly.
Downloaded 4.3.4, loaded on USB. The bootloader detected the new firmware and installed properly.

The next firmware version is 4.4.0. It contains 2 .bbf files, unlike previous firmwares which are only one file. Download, loaded both files on USB, tried to install.

ERROR #12603. Firmware file has invalid size.

USB drive is Fat32, with "Allocated Unit Size" 2048 bytes. Reformatted drive, same specs, tried again. Bootloader bypasses firmware files. Tried double-click on bootload, same error.

CANNOT go from 4.3.4 to 4.4.0.

Posted : 30/10/2023 2:08 pm
RE: Unable to update firmware

The fix that worked for me-

Get 4.3.4 stable. Then to go from 4.3.4 to 4.4.0:

Load USB with only this file: mini_release_boot_update_pre_4.4_4.4.0+4180.bbf

It was detected, and worked for me. Then the process will stall, saying it's "looking for BBF". Pull out the USB, copy the other file to the USB: mini_release_boot_4.4.0+4180.bbf.

It should be detected, and continue installing. Mine did some weird auto-restart, and installation twice. But it emerged with stable 4.4.0.

Then to update to 4.4.1, I put BOTH files on the UDB, inserted, turned on the printer. It worked...

Posted : 30/10/2023 4:15 pm