Notifications
Clear all

Some prints won't start  

  RSS
Gary Fixler
(@gary-fixler)
Member
Some prints won't start

This started happening when I upgraded a month ago from firmware 5.0.1 to 5.1.0 on my MK4. Many thumbnails from .gcode files on my thumbdrive no longer showed on the printer's screen, and whenever they didn't, the print would also fail. It wasn't just moving to .bgcode format, because many - but not all - old files had the same issues. I downgraded (the wrong way, and lost all the print history on the machine), and was able to get back to work. I upgraded again later, and it all seemed to work. I thought it was solved.

I haven't updated anything since, but now I'm again having prints fail. I couldn't upload any pics here, so I put them in a google photos album:

https://photos.app.goo.gl/PzV5WS6PeEaeUHt59

Oh, and I tried switching back to .gcode, and opening it in the gcode viewer from the slicer's menus, and it worked in there, but still - .bgcode and .gcode - wouldn't work on the printer, as described above.

This time the thumbnails are actually showing, but the same problem happens:

I click Print on the machine. I hear the motors engage. The red light on the bed heater cable goes on, the screen goes black, and says PRINT in the top left, and shows the USB drive icon in the top right, and that's it. It sits there in silence, every time, for 30 minutes, until it beeps and says it's shutting off the heating element due to inactivity.

I can't seem to find anyone else in the forums or internet at large with this issue, which is a bit concerning. The slicer is all updated to the latest. I also tried upgrading the printer today to 5.1.2, and the slicer says it's the latest at 2.7.1.

If it helps any, I set the printer up for 4 extruders, and split it into 4 parts by height, each using a different extruder (PLA colors).

The model is here:

https://www.printables.com/model/676195-snowflake-coaster-set-fixed-stls

...with the color splits as described here:

https://www.printables.com/model/671674-snowflake-coaster-set/related

This topic was modified 4 months ago by Gary Fixler
Posted : 23/12/2023 10:43 pm
ironfan72
(@ironfan72)
Trusted Member
RE:

Because you mentioned 4 extrudes I think the problem is a known bug with multicolor prints. 

The workaround is to start the print from PrusaLink or PrusaConnect NOT from the printer itself. More info can be found in other threads such as this one,

https://forum.prusa3d.com/forum/english-forum-original-prusa-i3-mk4-how-do-i-print-this-printing-help/single-extruder-mm-print-wont-start/

as an aside the model you mention seems to have colors on separate layers so you don’t need to have multiple extruders defined you can do it all with a single extruded and later changes. That way you can start the print directly on the printer. 

This post was modified 4 months ago 2 times by ironfan72
Posted : 24/12/2023 6:01 pm
Gary Fixler
(@gary-fixler)
Member
Topic starter answered:
RE: Some prints won't start

Thank you for saving my sanity. I googled every variant of Prusa, Prusaslicer, MK4, won't start, not starting, etc, and never found anything useful.

I also took working and non-working .gcode files, deleted all the actual printing bits, and diffed them in vim, slowly copying over chunks and trying to print the good one until it failed. It finally failed when I copied over some multi-value entries, like `value = 50,50,50,50`, so I guessed it was a multipart bug.

I'm now back to printing these stocking stuffers! With the extruder count back to 1, the  custom g-code for tool changes goes away, but I used the custom code in the slicer layers to throw in M600 and color purge code.

Thanks again! I look forward to an actual fix, so I can get back to multiple colors per layer.

Posted : 24/12/2023 8:11 pm
Share: