Notifications
Clear all

New 5.1.0 no image on screen  

  RSS
usmcsni
(@usmcsni)
Eminent Member
New 5.1.0 no image on screen

updated to the new firmware and all my old .gcode and even the new .bgcode won't show an image on the printers screen of what's printing anymore 

Posted : 24/11/2023 4:17 pm
kribjo
(@kribjo)
Member
RE: New 5.1.0 no image on screen

Hi usmcsni,

That is to be expected according to github-page image format has changed from png to qoi.

You need to use PrusaSlicer 2.7.0 or newer to reslice to support the new QOI format for now.

 

kribjo

Posted : 24/11/2023 4:55 pm
Tom Horsley
(@tom-horsley)
Trusted Member
RE: New 5.1.0 no image on screen

I noticed that. I think they said the old gcode preview images aren't compatible, but new stuff I sliced also never showed an image.

Posted : 24/11/2023 4:58 pm
kribjo
(@kribjo)
Member
RE: New 5.1.0 no image on screen

Sorry for the obvious question, but you've updated to PrusaSlicer 2.7.0?

Posted : 24/11/2023 5:12 pm
DrNick
(@drnick)
Active Member
RE: New 5.1.0 no image on screen

Same here. I am still on 5.0.1. and using prusa slicer 2.7.0, since 5.1.0 does not work on my printer. My old sliced files show the image on the printer screen but the newly sliced ones not, allthough I changed the print output from bgcode to gcode in the slicer settings. Even with Prusa Connect or Prusa Link images of the newly sliced objects cannot be displayed. Feels like a step back.

Posted : 24/11/2023 8:46 pm
Denis Ferrari
(@denis-ferrari)
Eminent Member
RE: New 5.1.0 no image on screen

Same here, just updated Prusa Slicer to 2.7 and MK4 to 5.1 and no more thumbnail on printer lcd.

Shouldn't the new binary gcode be fully supported by printer 5.1.0 stable fw?

Thanks 

Posted : 25/11/2023 10:02 pm
Mike01Hu liked
lschelvis
(@lschelvis)
Active Member
RE: New 5.1.0 no image on screen

Same here, firmware on 5.1.0 and PrusaSlicer on 2.7.0. No previews anymore...

Posted : 26/11/2023 9:15 am
Patrick.b
(@patrick-b)
Noble Member
RE: New 5.1.0 no image on screen

same here from ling time and worst !! can't send any files to link via slicer !!! so better not use 2.7 and beta fmw ..easy to say !!! i explain this probl on github and many post but no reply !! and the live chat !! forget i prefer not copy the help here .

Posted : 26/11/2023 10:09 am
Patrick.b
(@patrick-b)
Noble Member
RE: New 5.1.0 no image on screen

just do it without sending files from slicer and then you can't import the Bgcode into link !! very simple

prusalink update please .....with camera , control.........and more , in fact same as  prusalink + mk3s + rpiow , that work perfecto

Posted : 26/11/2023 10:27 am
kleistermeister
(@kleistermeister)
Member
RE: Neue 5.1.0 kein Bild auf dem Bildschirm

Do you have this setting active? 

 

Posted : 26/11/2023 5:28 pm
Ckobar
(@ckobar)
Trusted Member
no picture if I reslice old 3mfs

 

I‘ve also updated FW 5.1 and slicer.2.7.0

 If I start a new project in Prusa slicer and import an stl or similar ,the printer shows the thumbnail. (Also the upload is fast)

But if I open an old project, „3mf „ file, and reslice it. No thumbnail will show on the printer.( I ticked the new bgcode in the settings) and the upload is slow again.

what am I missing here ?

thanks

Posted : 27/11/2023 9:11 pm
Denis Ferrari
(@denis-ferrari)
Eminent Member
RE: New 5.1.0 no image on screen

Fw 5.1 and Prusa Slicer 2.7.0 here and even creating a new project then importing a .stl file then slicing and creating the bgcode, no way to let tje printer show the thumbnail...

What's wrong?

Posted : 27/11/2023 9:25 pm
Patrick.b
(@patrick-b)
Noble Member
RE: New 5.1.0 no image on screen

so far whatever you activate the prusa link don't accept the Bgcode , you can save your Bgcode in your folder then import thsi files to link , you'll see that not work  then u delete the B and save even it say no, but don't care , and then import again and it's ok

Posted : 28/11/2023 7:35 am
Share: