Mk4: files from connect are forever "waiting"
 
Notifications
Clear all

Mk4: files from connect are forever "waiting"  

  RSS
jbroggio
(@jbroggio)
Eminent Member
Mk4: files from connect are forever "waiting"

Hello,

 

Starting a few days ago, when I send files to the printer via PrusaConnect, they don't seem to transfer or start. They get uploaded to PrusaConnect and then just... sit, waiting. I have restarted the printer several times. Printer is ready and online, no apparent error messages. I am sending them directly from PrusaSlicer.

 

 

This topic was modified 3 months ago by jbroggio
Posted : 03/03/2024 7:05 pm
jbroggio
(@jbroggio)
Eminent Member
Topic starter answered:
RE: Mk4: files from connect are forever "waiting"

Update: this behavior does not seem to happen if I save the bgcode and upload it outside of the prusaslicer, ie drag it into connect - it prints normally in that method.  It seems like just sending direct from slicer to the printer isn't working.

Posted : 03/03/2024 7:15 pm
MVH3032
(@mvh3032)
Active Member
RE: Mk4: files from connect are forever "waiting"

Interesting. For me it does not work for me at all any more. Even clicking on the upload file in connect just loads it to connect then sits waiting. 
it has not worked for weeks now. I have to upload  via PrusaLink

Posted : 03/03/2024 7:22 pm
N8&Joey liked
Scott
(@scott-19)
New Member
RE:

Anybody know if there is an update on this???

I'm having exactly the same problem. Prusa Connect is failing. It is connected to the printer (I can drive the Axis and move to home etc.). 

On the Prusa Connect status on teh printer it is constantly flashing as "Connecting" with the status showing as "Bug". Any sent files simply get to about 50% and show as "Waiting" on Prusa connect.

Was working fine 2 days ago. Really annoyed as I have only had the printer up and running now for a couple of days and mainly bought it for the wireless connectivity.

Posted : 04/03/2024 4:10 pm
L'Atelier de Florent
(@latelier-de-florent)
Active Member
RE: Mk4: files from connect are forever "waiting"

Same here with my mk4. Fortunaltly I stiil have a mk3s+ working fine (but slowly).

Does anyone have news about Pprusa ?

Posted : 05/03/2024 1:37 pm
Scott
(@scott-19)
New Member
RE: Mk4: files from connect are forever "waiting"

UPDATE - I have stumbled across a fix that works for me (& Hopefully others)

I went online with live chat and tried various things (Hard reset, connecting via a hotspot on the printer etc.). Nothing seemed to be fixing it.

I needed a print so placed a sliced file on one of my own USB drives. Once this was in the printer Prusa Connect was staying "Connected" with no errors.

I then tried to send a file via Prusa Connect and everything worked as it should.

I placed the Prusa supplied USB back in my Mk4 and immediately upon sending a file via Connect it went into "Connecting" status and also showed "Bug" as an error on the machine. The file went back to just sitting at about 50% of the transfer with the "Waiting" status.

So I would suggest to anyone having this problem that they give an alternative USB drive a go. I informed Prusa via live chat also so hopefully they will look at the USB drives for quality issues.

Posted : 05/03/2024 3:28 pm
Tojik
(@tojik)
Member Moderator
RE: Mk4: files from connect are forever "waiting"

Hi, you can also try removing any weird named files from the USB stick, however I am not familiar with possible causes for this. File sitting at 50% means that it uploaded to connect, but connect cannot get it to upload to the printer.

Posted : 07/03/2024 9:58 pm
jbroggio
(@jbroggio)
Eminent Member
Topic starter answered:
RE:

Not only do I still have the problem where I can no longer print files directly from Prusaslicer, I now additionally cannot drag and drop files from a folder into PrusaConnect. In other words, I can no longer print remotely at all, anymore. 

The network connectivity seems to just suck, period. It's constantly going offline, whether wired or wireless. 

 

I really regret getting the mark 4. I had been using Anycubic printers before and they worked great but required a fair amount of regular tinkering. I bought the far, far more expensive mark4 because it had some interesting features, and Prusa had a reputation for being a reliable workhorse. In reality most of the fancy features barely seem to work, and I've created more support threads in the 6 months of ownership with the mk4 than I did in the previous 6 years of Anycubics.

I guess I can swap the USB key? This would be the third one for this (again, 6 month old) printer, and I'm not sure swapping the USB key will fix the flaky network. And, of course, if I copy the files from a PC onto that USB key, it works fine. 

 

This post was modified 2 months ago 3 times by jbroggio
Posted : 14/03/2024 2:21 am
miltieIV2
(@miltieiv2)
Member
RE: Mk4: files from connect are forever "waiting"

I'm having the same problem.

I went down the corrupted USB drive path:
I inserted the USB drive into my Mac and it would not mount (there were some nasty power failures here recently).
I inserted it into my Linux machine and followed this: How to repair a corrupted FAT32 file system.
It did some minor fixes.

No change.

I inserted the USB drive into my Mac and tried Disk Utility again (the drive appeared this time).
I used Disk Utility to do a repair and it fixed some things.

No change.

I did not try the Prusa Slicer -> Plusa Link step.

I export the gcode from Prusa Slicer and went to Prusa Link to upload the file.
Firmware Bug: In Chrome, when you click to upload and select a file, it only searches for *.gcode (*.bgcode are greyed out).

I opened a file browser and did a drag and drop of the .bcode file.

--

The first time I tried to send the sliced file to Prusa Connect I got an error because the file name was too long:
Sierpinski-Pyramid-6_[Ziggy]_100mm_for_0.2mm_layer_height_and_0.4mm_nozzle_0.2mm_PLA_MK4IS_11h16m.bgcode
Shortening the file name to this got it to upload, but then stuck Waiting:
Sierpinski-Pyramid-6_[Ziggy]_100mm_for_0.2mm_0.4mm_0.4n_0.2mm_PLA_MK4IS_11h16m.bgcode

I'm wondering if the "[]" are causing trouble.

--

Firmware feature requests:
Change the Thumb Drive icon to one with a NOT (circle with a slash) over it if the filesystem is corrupted.
Add an option for a PrusaConnect status icon in the footer: C (connected), NOT C (no internet, no 200 from Connect, etc), C transferring, etc.

 

Posted : 14/03/2024 2:42 pm
karlc
(@karlc)
Member
RE: Mk4: files from connect are forever "waiting"

I tried your method and just wiped the USB drive and tried again and it kept failing. So I switched out to one of my own FAT32 USB drives and it works like a charm again. My Prusa provided USB was filled up with files with garbage looking names and one of them said a system file and was almost 32GB. Not sure if that's a print history or what it is but I don't print that often so I assume it's a glitchy file system and just accumulating junk. I also think the provided USB might be faulty to have it fail after only 3-4 months in my new printer. I also use a Bambu X1C and it is nearly flawless. It's my go to and not this glitchy Prusa anymore.

Posted : 13/04/2024 6:04 pm
Tojik
(@tojik)
Member Moderator
RE: Mk4: files from connect are forever "waiting"

Yup, the stock flash drives combined with the way our printers write to them equals trouble

Posted : 15/04/2024 11:31 am
MatthewMiller
(@matthewmiller)
New Member
RE: Mk4: files from connect are forever "waiting"

I had the same problem on my Prusa Mini+ and swapping in a different USB drive fixed it immediately. Thank you!  

PS: Prusa, seriously, this needs to be a high priority fix. It clearly is a problem with the firmware or PrusaConnect.

Posted : 28/04/2024 8:34 am
CyclonEngr
(@cyclonengr)
Active Member
RE: Mk4: files from connect are forever "waiting"

DITTO - I just started to have the same problem (transfer 50% and then 'stuck' on "Waiting...").  Coincidentally (?) I now have a new/strange gcode file at the top of my  printer file list, but I deleted it and still couldn't transfer.  After reading these posts I stuck a new USB drive in and now I'm printing.  It seems strange that the USB stopped working randomly, however we did recently have two power failures - printing resumed normally after the first one.  Did not on the second - had to reset and start print over.

Posted : 07/05/2024 8:38 pm
Volksswitch
(@volksswitch)
Active Member
RE: Mk4: files from connect are forever "waiting"

I was seeing the exact same thing happening on my XL.  I discovered that the USB drive that I had in the XL had several file folders on it that I couldn't delete - seemed to be associated with large bgcode files I had tried to upload via PrusaConnect.  I reformatted the USB drive to get rid of them - I was only offered exFAT and NTFS as options.  I copied the bgcode file to the drive and inserted it into the printer, but the display said there were no files on the drive.  After reading this thread, I dug up an old USB drive that could be formatted as FAT32, copied the file, and inserted it into the printer.  This time, it could see the file, and I started printing.

I just created another bgcode file and tried uploading it using PrusaConnect.  It wasn't quick but no more "Waiting" problem!  I wonder if the problem was solved by replacing the USB drive with a FAT32 formatted version.  Note that I was having success earlier with the exFAT USB drive so I don't know what changed.

I suppose Prusa could have made a change to PrusaConnect just now but this story all took place today.

Posted : 08/05/2024 12:02 am
Share: