Notifications
Clear all

Power not turning on...  

  RSS
David Stephenson
(@david-stephenson-2)
Active Member
Power not turning on...

So this is my third enclosure and first problem, when I turn the power on the little LCD monitor at the front does not turn on. 

How do I go about troubleshooting this one?

The wires all seem to be attached properly to the PSU.

Posted : 24/01/2023 11:10 am
Hello
(@hello)
Reputable Member
RE: Power not turning on...

Does the light on einsy turn on

Posted : 24/01/2023 8:38 pm
René
(@rene-3)
Trusted Member
RE: Power not turning on...

Are the two ribbon cables connected to the correct connectors?

The cable with one black band on EXP1 and the cable with two black bands on EXP2?

 

Posted : 25/01/2023 7:44 am
David Stephenson
(@david-stephenson-2)
Active Member
Topic starter answered:
RE:

The light on the einsy turns on, the ribbon cables are inserted correctly into the back of the display (one band to exp1, two bands to exp 2)

 

This post was modified 2 days ago by David Stephenson
Posted : 25/01/2023 8:36 am
Hello
(@hello)
Reputable Member
RE: Power not turning on...

How olds printer if it's less then a year old contact prusa on live chat as it might be faulty lcd also check contrast knob on back of lcd

Posted : 25/01/2023 8:41 am
David Stephenson
(@david-stephenson-2)
Active Member
Topic starter answered:
RE: Power not turning on...

Sadly I think this one is over a year old, worked perfectly before I put it in the enclosure... may need to try and source some ribbon cables to see if that is the problem. 

Though I am intrigued by the contrast knob, I've not noticed one before. 

Posted : 25/01/2023 12:49 pm
David Stephenson
(@david-stephenson-2)
Active Member
Topic starter answered:
RE: Power not turning on...

Is it possible that the ribbon cables could be the source of failure...

Posted : 25/01/2023 12:53 pm
Hello
(@hello)
Reputable Member
RE: Power not turning on...

It is possible but unlikely that both are to fail normally the backlight still turns on I'm wondering if the heat from in the enclosure is effecting something have you take out of enclosure to see also if you touchd the einsy or the lcd static discharge can happen and frie the lcd 

What I want you to do is scroll down by guessing using the nob to where you think preheat is and click it if it starts heating up it's bad lcd

Posted : 25/01/2023 9:00 pm
Hello
(@hello)
Reputable Member
RE: Power not turning on...

Also when you click there is normally a noise if this happens the contrast has been changed or bad lcd

Posted : 25/01/2023 9:02 pm
David Stephenson
(@david-stephenson-2)
Active Member
Topic starter answered:
RE: Power not turning on...

I'll have a look at both of those tomorrow, I was earthed the whole time I was working with the enclosure so hopefully static will not have taken out something expensive

 

Posted : 25/01/2023 9:41 pm
Hello
(@hello)
Reputable Member
RE: Power not turning on...

It's not about being earth for static electricity if you touch top screw of PSU it will take away static I always do this.

Posted : 25/01/2023 10:07 pm
David Stephenson
(@david-stephenson-2)
Active Member
Topic starter answered:
RE: Power not turning on...

The good news is the LCD is not fried, I plugged it into another unit with no problems, so still having the same issue with this unit though.

What is the next probable cause?

Posted : 26/01/2023 3:45 pm
René
(@rene-3)
Trusted Member
RE: Power not turning on...

The first thing that comes to my mind is that one or both ribbon cables are causing a problem.

Posted : 26/01/2023 4:05 pm
Hello
(@hello)
Reputable Member
RE: Power not turning on...

You said you pluged it into another unit so use theme ribbon cables

Posted : 26/01/2023 11:44 pm
Hello
(@hello)
Reputable Member
RE: Power not turning on...

It could also be the einsy

Posted : 26/01/2023 11:45 pm
René
(@rene-3)
Trusted Member
RE:

Check whether there is 5V on pins 1 and 2 of connector P1.

If so, check whether this 5V is also present at the end of ribbon cable 1.

This post was modified 2 hours ago by René
Posted : 27/01/2023 7:13 am
René
(@rene-3)
Trusted Member
RE: Power not turning on...

 

Posted by: @david-stephenson-2

The good news is the LCD is not fried, I plugged it into another unit with no problems, so still having the same issue with this unit though.

What is the next probable cause?

To measure is to know, our teacher always said,

so it's time to start using the multi-meter 😊 

Check whether there is 5V on pins 1 and 2 of connector P1.

If so, check whether this 5V is also present at the end of ribbon cable 1.

Posted : 27/01/2023 7:26 am
Share: