Notifications
Clear all

Artillery x2 on PrusaSlicer  

Page 1 / 2
  RSS
M P
 M P
(@m-p)
Active Member
Artillery x2 on PrusaSlicer

Hi all

I am a Prusa printer user but I decided to purchase an Artillery x2 just for its build capacity. I’m using PrusaSlicer 2.5 but I have an issue. The filament runout works and pauses the print for reinstalling of the filament but when pressing resume it doesn’t extrude.

This is the same for just simply pausing the print, after pressing resume it goes on its merry way but without extruding filament.

This is a big issue and I know this isn’t an Artillery forum (because there isn’t one) but I’m reaching out to find the solution. I’ve found others have the same issue.

please advise, thanks in advance 🙏

Posted : 06/10/2022 4:46 pm
RedDawg
(@reddawg)
Reputable Member
RE: Artillery x2 on PrusaSlicer

It sounds to me as if you are not getting the filament loaded correctly after a pause or runout. Do you have a "visualizer" on the extruder motor to confirm it is actually turning? If so, and it indicates filament SHOULD be extruding, but it's not, that sounds like a loading issue. If the visualizer is static, that would be something different, but I can't see why PrusaSlicer would be the reason.

Hear ye, Hear ye! Step right up folks and get your Government salvation here! Less than $.002 per word! Amazon.com/dp/B0B8XMMFP4

Posted : 06/10/2022 5:27 pm
M P liked
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

Hi and thanks for the reply.

The extruder simply doesn’t extrude as in the mechanical motion. It moves the correct location and carries on as though it was printing.

Incidentally a test print supplied with the printer works fine, pause/resume and load filament.

Ive contacted Artillery but got nothing back yet, I’ve opened a chat on Reddit and only found others with the same issue. Unfortunately I’m not experienced enough with this to even guess. I want to do a large print and swap out the filament but can’t with this issue.

Thanks again.

Posted : 06/10/2022 5:43 pm
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

An update. Others with this issue have tested slicing with Cura and Prusa and the Cura gcode works fine with the tests mentioned, doing the same tests with Prusa results in what I’ve described.🤪

I prefer PrusaSlicer over Cura and I would like to get to the bottom of this.🙏

Posted : 06/10/2022 7:44 pm
RandyM9
(@randym9)
Reputable Member
RE: Artillery x2 on PrusaSlicer

I don’t know anything about the Artillery X2 but I would start by comparing the start GCode from the file supplied with the printer (that you state paused & resumed successfully) to the start GCode from one of your files to see if you can spot something different?

It’s unclear to me what could be happening but maybe the GCode will have a clue. 

There are users of the Artillery X2 on this forum so my guess is someone here will have some better advice. Good luck.

Cheers

Posted : 06/10/2022 7:49 pm
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

Hi. Yes I had thought of comparing two sets of gcode, I’m hoping it will be quite obvious when I look.

Cura must be doing something that Prusa doesn’t as two identical Stl files one sliced with Cura and one on Prusa and only Cura works. Only difference I can say there is Cura has Artillery x1 (not x2) available in profiles. 
Thanks for your comment 👌

Posted : 06/10/2022 7:55 pm
RandyM9
(@randym9)
Reputable Member
RE: Artillery x2 on PrusaSlicer

Hope you get it sorted. Keep us posted.

Posted : 06/10/2022 8:02 pm
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

Many thanks I will do.

I really think Artillery ought to make some effort with this as it’s seems to be a common issue, I have asked them.👍🏻

 

Posted : 06/10/2022 8:06 pm
Henry Thomas
(@henry-thomas)
New Member
RE: Artillery x2 on PrusaSlicer

Have you looked into whether the Cura G-Code is using relative or absolute position for the E0 (extruder)? Are the nozzle temps OK, extrusion can disable if the temp drops below a minimum threshold - I know thats kind of obvious but sometime we miss the obvious.

Posted : 07/10/2022 5:28 am
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

Hi. Everything is ok other than the actions I describe. Over the weekend I’m going to see how the gcode from one that doesn’t work to one that does.

Thanks for your reply 

Posted : 07/10/2022 5:48 pm
towlerg
(@towlerg)
Noble Member
RE: Artillery x2 on PrusaSlicer

Seems that by default "Pause print G-Code" has M601, does your firmware resond to that?

Posted : 08/10/2022 2:41 pm
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

I assume so due to the fact everything works fine if sliced by Cura x1 Profile

(I have x2 printer )

I did look at the two geodes side by side (Cura gcode verses Prusa gcode) but I couldn’t see what was responsible within Cura to execute the features and if at all there will be.

Posted : 08/10/2022 3:01 pm
M P
 M P
(@m-p)
Active Member
Topic starter answered:
RE: Artillery x2 on PrusaSlicer

When gcode is generated within our slicer does it put lines of code for pause/resume and filament runout automatically or is it the custom profile that enables this ? 
I’ve looked for Artillery x2 profile for PrusaSlicer 2.5 but found nothing.

I really prefer PrusaSlicer of Cura slicer but I can’t use it due to the lack of pause/resume and filament runout functions. ☹️☹️ Prusa people please advise me 🤞🤞🙏

Posted : 08/10/2022 3:07 pm
towlerg
(@towlerg)
Noble Member
RE: Artillery x2 on PrusaSlicer

In youPrusaslicer profile what do you have in the field Printer Settings/Custom GCode? And what do you have in the equivalent Cura field. I assume your printer is running a tweaked version of Marlin, do you know what version?

Posted : 09/10/2022 1:09 pm
towlerg
(@towlerg)
Noble Member
RE: Artillery x2 on PrusaSlicer

It would appear that M601 is a Prusa only GCode.

Posted : 09/10/2022 2:24 pm
Jaime
(@jaime)
Active Member
RE: Artillery x2 on PrusaSlicer

Exact same problem with both X2 and genius Pro.

It's not about M600 codes (which are supported and work). You can add them and the print job will halt and wait.

It's the act of pausing and then resuming using code generated by prusa slicer (best slicer ever by the way 😎 ) which bugs the printer.

It happens when you pause it with the touch screen in the printer.

It happens if you try to change the filament in the menu.

It happens if you run out of filament, the sensor halts the printer, you change it and the resume.

Pause and then resume in any possible way and the printing will go on with the extruder "moonwalking" back and forth without actually pushing the filament. Really funky but useless.

Running the exact same file through Cura allows me to pause and resume without any problem. Zero. I can change filaments, colors, add magnets, and it will resume flawlessly. That means it’s not any kind of hardware related problem.

It has to be something in the way the code is structured that the printer no longer is able to interpret the extruder lines once it stops. 

Hope somebody can help us 😥 🙂 

Posted by: @m-p

Hi all

I am a Prusa printer user but I decided to purchase an Artillery x2 just for its build capacity. I’m using PrusaSlicer 2.5 but I have an issue. The filament runout works and pauses the print for reinstalling of the filament but when pressing resume it doesn’t extrude.

This is the same for just simply pausing the print, after pressing resume it goes on its merry way but without extruding filament.

This is a big issue and I know this isn’t an Artillery forum (because there isn’t one) but I’m reaching out to find the solution. I’ve found others have the same issue.

please advise, thanks in advance 🙏

 

Posted : 26/11/2022 1:31 am
Neophyl
(@neophyl)
Famed Member
RE: Artillery x2 on PrusaSlicer

And so far no one has provided gcode examples for some simple like a 20mm cube sliced by both Cura and PS that can be compared side by side. They mentioned they were going to compare but then nothing. And without anything to work with it is unlikely that anyone can help.  

Posted : 26/11/2022 8:12 am
Jaime
(@jaime)
Active Member
RE:

Thanks a lot for the prompt reply.
There you go. 

Cube_Prusa_Slicer_for_Artillery_Genius_default_all

Cube_Cura_for_Artillery_Genius_default_all    Links edited by Joan (Moderator) to remove faulty links

It's just a tiny 20x20x20 cube using Prusa Slicer and Cura default profiles for Artilley Genius Pro (same as artillery genius)
Nothing changed. Default everything. 

If you pause Prusa Slicer print job and then resume, it will continue the right path but extruder motor keeps moving back and forth in erratic movements with no  actual extrusion.

Same operation with Cura and everything works as expected. 

Thank you again for your response and I hope it helps you. 

 

Posted : 26/11/2022 10:02 am
Neophyl
(@neophyl)
Famed Member
RE: Artillery x2 on PrusaSlicer

Sorry I don't download from random sites.  Nothing personal just natural caution.  If you want to attach anything then you need to zip it up and attach directly to a post.

Posted : 26/11/2022 12:40 pm
Jaime
(@jaime)
Active Member
RE:

There you go.
Hope it works for you now.
Thanks.

Cube_Prusa_Slicer_for_Artillery_Genius_default_all

Cube_Cura_for_Artillery_Genius_default_all

This post was modified 4 days ago by Jaime
Posted : 26/11/2022 12:45 pm
Page 1 / 2
Share: