Vaciar todo

Flash firmware using USB  

New Member
Flash firmware using USB

I have tried flashing the board via ICSP and it seems fine, but nomatter what bootloader I am flashing, the USB port does not expose a serial port.

I have also tried with Arduino IDE using the Prusa Board definition, but still no USB serial.

Anyone with a working solution?

Respondido : 25/08/2021 12:43 pm

Have you asked support?  I just now installing my MM2S and I am interested if this is common problem and if they have a recommended solution.  

Chuck H
3D Printer Review Blog

Respondido : 25/08/2021 3:42 pm
Reputable Member
RE: Flash firmware using USB

Not sure if I understand exactly what you did. You say you flashed the board, but now it isn't seeing the USB anymore?


One thing that happened to me was that I didn't use the correct USB cable. I couldn't find the cable the came with the MMU so I tried a few of the many micro USB cables I have and couldn't connect to the MMU. When I finally found the original cable it worked without problems.

No idea why, but not all cables seem to work.

Respondido : 25/08/2021 5:38 pm
New Member
Topic starter answered:

The USB never worked. I don't know if it is supposed to out-of-the-box. And neither did support.

The board is not connected to any printer, as it is intended for a custom project.

I am just looking for a way to flash the board, so I afterwards can flash using USB.

Respondido : 25/08/2021 5:53 pm
Illustrious Member
RE: Flash firmware using USB

Reflash the bootloader for the MMU2 with a simple USBASP programmer: Caterina-prusa_mm_control ( https://github.com/prusa3d/MM-control-01/issues/24)

After that, I was able to flash the firmware via USB without any problems.



Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen.

Respondido : 25/08/2021 6:36 pm
New Member
Topic starter answered:

Karl, I tried that again and still same result.

Arduino IDE reports success on burning bootloader and debug output shows fuses to be correct, but still no COM port avaible when plugging the board to the PC.

Respondido : 01/09/2021 2:44 pm