Notifications
Clear all

Y-axis crashes  

Page 4 / 4
  RSS
Hamaidh
(@hamaidh)
New Member
RE: Y-axis crashes

Hi,

I had "crash detected" problems after running the printer after a long lay-off. I ended up taking the printer apart as much as I needed to re-work the lubrication and seating of the X and Y axes. This had no effect, I then tackled the Z axis and reset and lubricated this. Still no joy, same problems. I ran a full new set up calibration, still same problem seen. Then further reading of the forum led me to realise that I had recently updated the firmware to 3.12. I have now reverted to 3.11 and lo and behold printer is working again even better than before due to the maintenance in looking for the problem!

 

Thanks to Joel for this clue.

Hamaidh.

Posted : 21/06/2023 3:30 pm
circlesmiler
(@circlesmiler)
Member
RE: Y-axis crashes

I could solve this kind of problem (crash detection problem, "Wrong Y axis length") by doing a factory reset. I think because of some firmware updates and maybe old preferences that are not compatible, the problem occurs.

Posted : 25/06/2023 7:21 pm
ben feher
(@ben-feher)
Member
RE:

So i think i found part of it. i think that at certian points the x axis and yhe y axis electric cable overlap in such a way that causes the y axis (shorter cable) to stall. This causes a crash, the printer resets axis and hopefully cables in diffrent positions. If not, crash repeats. I took two rubber bands from a disposable mask and tied the middle x axis cable to the center of the top frame. Seems to have fixed it

This post was modified 12 months ago 3 times by ben feher
Posted : 06/07/2023 7:40 pm
Axel
 Axel
(@axel-6)
Member
RE:

Hi,

after several years of no problems with my MK3S, I started printing PC (275° hotend / 110° bed) in side an enclosure. This had been no problem for months and I got pretty PC prints in my housing.

 

At the last weekend, I had to print some Prusa parts, because the original PETG parts simply melt away (Pinda holder on extruder body, fan-shroud). Not to say that this is a shame for a printer, that has the capability to print PC and ABS out of the box (which always need a housing). Understand me right, I am a Prusa guy, but the is really not well-designed.

Out of a sudden, I encounter Y-Chrashes. I did the firmware upgrade a  couple of weeks ago, when I installed Prusa Slicer 2.6.
Also, when the printer is in a cool environment, and I move the Y-axe via the Prusa control, I encounter at about 70 mm, that the motor shudders.

I then turned off the crash detection (stealth mode), so the print went on. But as you can see on the next picture, which is the new extruder-bodystl, the crash occurs more or less regularly after a certain amount of time.

Y-Crash

I hope, I find a solution.

But I have to say, that I really rely on the printer making a lot of part for astronomy telescope making. This is an absolute showstopper. I cannot invest much more time in fixing things, that should work as intended and might lead to a change of the printer (company). I hope, that someone at Prusa is reading this.

Cheers Axel

Posted : 25/08/2023 8:56 am
Axel
 Axel
(@axel-6)
Member
RE:

As I encountered now, the Y-belt-tensioners under the heat bed (which is insulated!), did melt. So they scrubbed against the housing (around y = 70). I fixed it temporarily with tying them together and will now print some new parts in PC. I hope this will last for the print, and afterward the problem will not occur anymore.

If the issue comes up again, I will report. If not, the case is fixed, and I won't comment again  (and in this case Mea Culpa blaming the printer or Prusa. But as I said, such parts should be mad out of temperature resistant material in the first place!).

Cheers Axel

This post was modified 10 months ago 3 times by Axel
Posted : 25/08/2023 9:43 am
Rob Norris
(@rob-norris)
Member
RE: Y-axis crashes

I had the same random Y-axis crashes with auto reset and continue printing on a brand new factory assembled MK3S+, not running in an enclosure. I noticed the Y-axis belt drive gear on the stepper shaft was not centered on the belt. One edge of the belt was rubbing on the gear flange. Belt tension was in spec. After repositioning the gear on the stepper shaft so the gear was centered on the belt, the random Y-axis crashes stopped. No crashes since making this adjustment. So far I have printed 4+ kg PLA and 1/2 kg of PETG.

Posted : 31/08/2023 3:40 pm
Freaky Stylie
(@freaky-stylie)
Member
RE: Y-axis crashes

Many thanks to all of the people who have posted to this discussion, it has been helpful in troubleshooting my own Y-axis crashes. 

After years of printing without trouble, I suddenly started experiencing this issue. I initially took the maintenance steps described in other posts and here: https://help.prusa3d.com/article/crash-detection_2100 but they didn't help, which is how I ended up on this thread.

While I don't have anything further to add about the mechanism for these mysterious Y-axis crashes, I can corroborate from my own experience that it does seem to have something to do with excessive heat. In my case, my "enclosure" is a closet where my printer is located. With the door closed, it can get quite warm in there, I'd guess 25-30C.

To resolve my issue I made the following changes:

  1. Positioned print at the back of the print area in order to minimize how much time the Y-axis motor was under the heated bed
  2. Left the closet door open
  3. Turned on A/C in the room (Ambient temp by the printer was about 19C)

So, for me, keeping things as cool as possible was the quick fix. I don't have any insight into why this issue started now (perhaps the firmware upgrade that others have talked about, I don't recall when I upgraded, and how big my prints have been since then)

Posted : 11/09/2023 6:37 pm
Markus liked
FerTech
(@fertech)
Trusted Member
RE: Y-axis crashes

You seem to really got it! Because I loose a bit that screw and I am not having anymore crashes since a while or at least they are being significantly reduced. Will let you know if the positiveness continue in the next hours as I am printing a looooong print. 

For anyone trying to figure out which screw needs to be losen a bit, is this one:

Posted : 26/10/2023 5:22 pm
Dynamo
(@dynamo)
Active Member
Topic starter answered:
RE: Y-axis crashes

In the long run it reduced the amount of crashes for me. I did not get rid of them fully. If I use it in an enclosure, I still feel I get more crashes than without the enclosure. Maybe the tight screw of was the root cause and cause to much load on the corresponding motor. Maybe it is now "broken" and leads to the crashes.

Another observation that I have: If I print in the enclosure with the door open and an external fan at the back, I get very little crashes, often times none.

Next printer will not be from Prusa. So many people having the issue, still no support.

Posted : 26/10/2023 9:06 pm
Harms3D
(@harms3d)
Active Member
RE: Y-axis crashes

I have the same problem now with my mk3s with MMu2S factory assembled. This is in an Enclosure that runs on a PWM fan. Just print a lot of PCCF and in the case are mostly 39 ° C. Also, the cables from the heater bed are angled in the back with the modification. This has worked so well for a long time. I think I will turn off the crash detection now as well.

Posted : 28/10/2023 4:45 pm
Markus liked
Valda
(@valda)
Active Member
RE: Y-axis crashes

For me helped to add thermal pad between Y-motor and frame. Dont forget to add distance pad between motor holder and frame with same -0,2mm thickness. The angle of motor axe must be the same as original (other way you may damage the belt or change its resistance).

In my case is temperature of motor about -5°C lower. I testing it only 2 days and I have 0 Y-crash errors (ambient temperature is about 25°C)

Btw. thermal pad is used on MK4 model in standard.

Posted : 31/03/2024 8:00 am
Markus liked
Nick S
(@nick-s)
Member
RE: Y-axis crashes

After spending about 8 hours debugging phantom Y-axis crash issues on my MK3S+ I wanted to share my findings in case it can help out anyone else!

Like a lot of you my model that was causing issues was mostly cylindrical. I don't use an enclosure, and my Y-axis stepper and stepper drivers weren't getting particularly warm. In the end the problem seems to be my custom slicing profile interacting poorly with the crash detection logic of the printer.

My profile uses the max volumetric speed feature of PrusaSlicer ( https://help.prusa3d.com/article/max-volumetric-speed_127176 ). I've set a max volumetric flow rate of 10mm3/s and set normal perimeter/infill/etc speeds to "0" which lets PrusaSlicer set speeds automatically. Importantly all acceleration and jerk settings are the stock defaults, which should cap any sudden Y movements to acceptable values. I've used this profile without issue for months with really good results, a nice balance of speed and quality.

The problem seems to be that this slicing profile caused the Y-axis to make some very rapid start/stop motions on the particular model I was printing. I have no way of knowing if these moves were actually exceeding the slicer acceleration/jerk settings but they sure sounded terrible, like grinding! I ended up doing a full teardown and repacking of the bearings thinking something had gotten damaged 😭. Once I was sure the Y-axis was butter-smooth, I realized the slicer could be involved I resliced with stock settings and  the print finished with no Y-axis crashes.

Summary: it'd be really useful to know what slicing profiles people who are experiencing this issue are using. If you're using something custom, my recommendation is to try your model with stock settings, even if it's painfully slow, just as a comparison point. And more than anything I hope my pain can be a reminder to consider that slicer settings could be affecting things!

Posted : 05/04/2024 10:14 pm
Markus
(@markus-6)
Active Member
RE: Y-axis crashes

 

Posted by: @steve457

I just disabled the crash protection in the printer settings, and haven't had any issues since doing that. Ideally, I would like to have crash protection enabled, but it doesn't seem to work correctly.

Two years later, and it still happens to me. Specifically,when doing long-ish prints with PC CF in a temperature controlled enclosure (set to <50°C, actual temperature around 45°C), usually after ~5 hours of printing (while printing the Mk.4/MMU 3 upgrade parts...).

Thanks for the hint with disabling crash protection. I also dialled down the enclosure temp to <40° C, hoping either or both measures will let me finish printing those upgrade parts. And yes - I am already prepared to improve cooling of the Trinamics for the Mk.4, see Walter's printable at https://www.printables.com/model/580484-cover-for-adding-an-80-mm-noctua-fan-to-the-mk4-el .

Posted : 27/04/2024 12:30 pm
Rob Latour
(@rob-latour)
Eminent Member
RE: Y-axis crashes

I'm having this problem too - using PTEG for a cylindrical model.   I tried a variety of the suggestions above, but none worked for me.  However, I then put my gcode thru this OctoPrint addon  https://plugins.octoprint.org/plugins/arc_welder/ and the issue seems to have gone away for the print I am printing now (however, the first layer looks rough).  In any case, in my case, I think it may be slicer related.  I am currently using PRUSA Slicer 2.7.4+ Windows.

Posted : 28/05/2024 11:00 pm
Maksym
(@maksym)
Active Member
RE:

 

Posted by: @rob-latour

I'm having this problem too - using PTEG for a cylindrical model.   I tried a variety of the suggestions above, but none worked for me.  However, I then put my gcode thru this OctoPrint addon  https://plugins.octoprint.org/plugins/arc_welder/ and the issue seems to have gone away for the print I am printing now (however, the first layer looks rough).  In any case, in my case, I think it may be slicer related.  I am currently using PRUSA Slicer 2.7.4+ Windows.

That's a nice workaround.

Slicer does not fix nor introduce the issue, since the issue is in the hardware / firmware. However, you can definitely slice the model in a way that reduces or eliminates the conditions that lead to the crash - all you need to do is avoid a rapid acceleration coming out of a 180-degree U-turn on Y-Axis in your path.

When doing circle-like perimeters, the stock slicer likes to abruptly change directions. Say, you are doing an outer perimeter clockwise, reach the seam at full print speed, then tell the printer to jump to the adjacent inner perimeter and do it anti-clockwise, also at full speed. The moment the bed changes the direction and has to decelerate / accelerate causes the Y-Axis stepper to draw a lot of current (to overcome the inertia from the bed). This current exceeds a reporting threshold and gets reported as a possible crash. And the warmer the motor is - the more current it draws - the closer it gets to the reporting threshold in these U-turns.

The plugin seems to be reducing the 180-degree u-turns with arcs. This reduces the jitter (bed jumping back and forth) and, likely, also reduces the load on the motor.

 

 

This post was modified 3 weeks ago by Maksym
Posted : 28/05/2024 11:32 pm
Rob Latour
(@rob-latour)
Eminent Member
RE: Y-axis crashes

as an update, I am still getting crashes but far far fewer than before.

Posted : 29/05/2024 3:11 am
torqueplane
(@torqueplane)
Member
RE:

Like many others in this thread, I had no issues with my i3 MK3S+ for a really long time, but then suddenly began experiencing a lot of false Y-axis crashes. This was much more likely to happen when printing cylindrical models and when the printing environment was really warm. I tried a lot of different proposed solutions, but the thing that finally solved this for me was to decrease tension on the Y-axis belt.

I think one possible cause is that some printers (that ones run into this phantom Y-axis crash detection problem) have a Y-axis belt that is a bit too tight to begin with. Under many conditions, the printer works just fine despite the belt being a bit too tight. But when there are high printer environment temperatures (during hot weather, when using an enclosure without enough ventilation, etc.), the printer Y-axis might get a tiny bit longer due to thermal expansion, or possibly the stepper motor requires more current under higher temps. If the problem is thermal expansion, this extra length when hot then creates extra tension on the Y-axis belt.  In either case, the printer crosses over the threshold to where it starts thinking the Y-axis is crashing due to excessive current consumption on the Y-axis stepper motor.

It's very easy to try this solution on the MK3:

1. Check your Y-axis belt tension value: https://help.prusa3d.com/article/crash-detection_2100#check-the-tension-of-your-belts

     a. Menu: Support > Belt Status

     b. If the Y-axis belt tension value is near or under 240, your belt is too tight.  Move on to step 2.

     c. If the Y-axis belt tension value is good (~275), this solution will likely not solve your phantom Y-axis crashing issue.  Try other solutions.

2. If your belt is too tight, lower the tension:

     a. I accomplished this by backing out the two screws holding the front Y-axis belt idler, to create a small (approximately 1mm) gap between the belt idler and the frame.  See Prusa photo below.  The gap opens between the blue arrows in the photo.

     b. Find the two screws labeled with the purple arrow in the photo.  Back out both screws the same amount, a few turns to start with.  This was easy to do when using a ball-end hex key.  Back out the top screw from above and the bottom screw from below the screen, no need to remove the screen.

3. Check Y-axis belt tension:

     a. Menu: Calibration > Belt self test

     b. Check that the Y-axis belt tension value has increased away from 240 and is ideally somewhere around 275 (as this value increases, the belt tension is decreasing).

     c. If the value is increasing but not yet near the ideal 275, keep backing out both screws and run the self test to recheck the tension until the value is good.

4. Confirm that this solution worked:

     a. Print a model that previously failed for you due to phantom Y-axis crashes under similar temperature conditions. If it prints okay, then reducing your Y-axis belt tension likely solved your problem.

     b. If it worked for you (or you had high belt tension, but lowering the tension did not work), please reply to this post so others know what works to solve this frustrating issue!  Good luck!

 

Prusa photo: Back out the two screws (purple arrow) a little to increase the gap (between the blue arrows), between the idler (orange component) and the frame.

This post was modified 3 days ago 3 times by torqueplane
Posted : 16/06/2024 6:28 pm
Page 4 / 4
Share: