Notifications
Clear all

Unwanted filament changes on every print!  

  RSS
mgantner
(@mgantner)
Eminent Member
Unwanted filament changes on every print!

Hey all!

I'm experiencing requests for filament changes with every print. It seems to have started after disconnecting my MMU2, but not sure 100% on that timing.

It's not totally random, but seems to happen between layers even though I haven't added any color changes. I thought it could be related to the filament sensor, but given it doesn't happen randomly, it doesn't make sense for that. I downgraded to the previous prusaslicer thinking its a slicer bug, but it's still happening.

I've attached the gcode. Can anyone see anything in there that could be causing this issue?? 

Thanks!, it's driving me crazy!!

Posted : 19/11/2023 5:02 am
mgantner
(@mgantner)
Eminent Member
Topic starter answered:
RE: Unwanted filament changes on every print!

Ok, figured out the file posting issue. Gcode attached.

If anyone can figure out what is going on I would so appreciate it! It's made printing anything so painful.

Posted : 20/11/2023 8:51 pm
mgantner
(@mgantner)
Eminent Member
Topic starter answered:
RE:

Anyone from Prusa that could tell me what hardware/sensor problem that would cause the printer to pause between layers(not random), many multiple times during prints, ask for the filament to be removed, then asks for new filament to be installed? There apparently isn't anything in the gcode causing it.

It's literally made my printer unusable.

Thanks

This post was modified 3 months ago by mgantner
Posted : 26/11/2023 9:56 pm
jfr33
(@jfr33)
Member
RE: Unwanted filament changes on every print!

Did you find a solution to your problem ? I am experiencing the same issue since I print with a spool of PETG prusament orange. Never had this problem before with PLA from several brands and with PETG from another source (Arianeplast). It's a shame because the print quality of prusament is superb ! Do you have the problem with many filament or only with a single one ? Thanks.

Posted : 10/12/2023 8:31 am
Robin
(@robin)
Prominent Member
RE: Unwanted filament changes on every print!

First thing I'd do: Set filament sensor to off in the LCD menu.

If that fixes the issue, you have identified  a miscalibrated filament sensor as the problem.

If at first you don't succeed, skydiving is not for you.

Posted : 11/12/2023 3:09 pm
jfr33
(@jfr33)
Member
RE: Unwanted filament changes on every print!

I tried that today and since 5 hours my printer works fine. Skydiving is for me . 😆  Now all that remains is to dissassemble the extruder .

Posted : 11/12/2023 3:44 pm
mgantner
(@mgantner)
Eminent Member
Topic starter answered:
RE: Unwanted filament changes on every print!

Not sure what the problem was, but I think it had to do with the fact that I disconnected my MMU2S. I've since upgraded to the MMU3 and haven't had the issue since.

Posted : 11/12/2023 4:10 pm
mgantner
(@mgantner)
Eminent Member
Topic starter answered:
RE: Unwanted filament changes on every print!

Thanks for the reply. I think the issue had to do with the disconnection of my MMU2S. Upgrading and reinstalling the MMU3S solved the problem. Thanks 

Posted : 11/12/2023 4:12 pm
Share: