Clear all

Pause Printing - 3S with MMU2s  

Eminent Member
Pause Printing - 3S with MMU2s

So I have been trying to embed magnets.   Pause print in PrusaSlicer looked good and I print via OctoPrint.   All looked good but first time seemed to go wrong.  I cancelled the print and it stuck in the extruder (forcing cleaning of the inside of the MMU)

Made some changes and tried again.  This time was not really paying attention and noticed the nozzel was in the air rather than printing half an hour or so after I put the magnets in.

Tried again but watched carefully after I put the magnets in.  this time it was clear the extruder was not rotating following the unpause despite the fact that the head was following a printing path.  Then I noticed the Nozzle temp was down at 120, hence why the extruder was not turning.

Seems following the pause the print is resumed okay but the nozzell was not reheated first.   Anyone seen this before and how do I put it right?



Posted : 03/08/2021 1:08 pm
New Member
Can confirm - print pauses (M601) are not handled correctly in recent firmwares/PrusaSlicer

Yes, I can confirm - when printing with active MMU (not MMU-single):
First try: pause just ignored/skipped (?!?), print continued as usual, filament change OK.
Second try: pause executed, hotend heater switched off, missed that fact... few minutes later realized that hotend cooled below filament melting point, so print cancelled.
Printed once again (restart in OctoPrint): pause executed, than manually raised temperature in OctoPrint, filament change OK.

As I realized: problem arises when MMU2 is actively used (filament change) and both filament change and print pauseat layer are used together (pauses are then ignored), or when filament change is performed via modifier (in that case hotend heating is disabled on pause and it is not resumed when print continues).

FV 3.10.0-4481 (MK3S) + 1.0.6-372 (MMU2)
Sliced with PrusaSlicer-2.3.2+linux-x64-GTK3-202107080721.AppImage (haven't tested on 2.3.3 yet)

In the past I've printed some fridge magnets and it worked OK - it was about September 2020, PrusaSlicer 2.2.0+linux-x64 (at least according to 3mf metadata), it looks like filament change was performed via modifier (as well as void for magnet).

Wojciech Penar

Posted : 03/08/2021 10:03 pm
Eminent Member
Topic starter answered:
working now

Thanks Wojciech,


I found the way to sort this was to get Octoprint to see M601 as a pause code and also get it to never send M601 to the printer.  This then meant it went perfectly.



Posted : 12/08/2021 2:55 pm