MINI+ Filament Sensor doesn't detect out-of-filament?
 
Notifications
Clear all

MINI+ Filament Sensor doesn't detect out-of-filament?  

  RSS
papercrane
(@papercrane)
Active Member
MINI+ Filament Sensor doesn't detect out-of-filament?

I recently had a print where I was using up the remainder of one spool of filament and planned to replace with another spool when it ran out. Unfortunately the filament ran out and the printer just kept trying to print with nothing coming out. Shouldn't the filament sensor catch filament-out conditions and pause the print?

Posted : 21/12/2021 11:05 pm
fuchsr
(@fuchsr)
Famed Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

Were you printing from the USB stick or Octoprint?

Posted : 22/12/2021 2:06 am
fortinmike
(@fortinmike)
Estimable Member
RE:

One thing to keep in mind is that the sensor can be disabled in the printer's settings, but it's not the only way it can be disabled. There are certain "ad-hoc" menu options (during filament change? I'm not 100% sure) that seem like they would be one-off decisions but effectively disable the filament sensor permanently instead of temporarily. I was caught off-guard by that once or twice. Make sure to read the messages carefully. Sorry I can't be more precise!

Posted : 22/12/2021 2:27 am
MysDawg
(@mysdawg)
Estimable Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

 

Posted by: @fuchsr

Were you printing from the USB stick or Octoprint?

My filament sensor has never worked when using OctoPrint

Posted : 22/12/2021 2:39 am
fuchsr
(@fuchsr)
Famed Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

That's why I was asking. It's supposed to work; never did in my hands.

Posted : 22/12/2021 2:46 am
fuchsr
(@fuchsr)
Famed Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

@papercrane

Did you check out https://help.prusa3d.com/en/article/ir-filament-sensor-troubleshooting-mini-mini_230431/?

Posted : 22/12/2021 2:52 am
papercrane
(@papercrane)
Active Member
Topic starter answered:
RE:

I print from Octoprint these days. The feedback I get from it is very nice.

I'll check to see if the menu option is on once the current print finishes (if I remember). The sensor works perfectly well when loading filament, so I know the sensor itself works.

Posted : 22/12/2021 8:22 am
fuchsr
(@fuchsr)
Famed Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

One of the firmware upgrades this year was supposed to fix the filament runout issue with Octoprint. From reports, it seems it works for some people. For whatever reason, it doesn't for me.

Posted : 22/12/2021 12:53 pm
papercrane
(@papercrane)
Active Member
Topic starter answered:
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I checked and the filament sensor is definitely set to on. I haven't run out of filament again to test, though.

Posted : 07/01/2022 8:08 pm
Chris Laudermilk
(@chris-laudermilk)
Estimable Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I was just thinking about this issue a few days ago. I've updated my firmware to the latest version (4.3.4), and Octoprint is the latest OctoPi install (1.7.2). I had filament break and the sensor seemed to work--the print stopped and the Mini sat there beeping at me until I reloaded the filament. Then the print continued normally.

Mini+ (kit) - Revo Micro

Posted : 10/01/2022 3:02 pm
Richard D
(@richard-d)
Trusted Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

The one time my filament sensor stopped working, it turned out to have been disabled by a firmware update (4.2 IIRC).

 

 

Posted : 11/01/2022 10:29 am
Bern Statch
(@bern-statch)
Active Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I think your main issue is Octoprint not supporting the Filament Sensor. I have read up on it and you need to get a new plugin for octoprint and play with the code a bit, I didnt think it was worth it so I havent attempted yet. 

 

 

Posted : 11/01/2022 7:56 pm
Bern Statch
(@bern-statch)
Active Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

If you are using the SD card and it stops working its probably due to the sensor either dirty in the inside or the magnet is not at the right sensitivity so if you unscrew it and reassemble looking for the 1 or 0 in the settings menu to change when you put a piece of filament in. 

Posted : 11/01/2022 7:58 pm
j.e.hahn
(@j-e-hahn)
Eminent Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I know that, since I upgraded to the bond tech ifs extruder, that my filament sensor works with octoprint. I don’t believe I’ve installed a filament sensor add on. 

If you have 4.3.4 installed, check your sensor actually works. From what I could see, when I checked, that release had the Git pull request containing the fix.

Also, the design of the integrated bond tech part is lovely. I really like mine. Was easy to install. (You do have to disassemble the stock sensor, though.)

Posted : 11/01/2022 9:53 pm
Sp4rkR4t
(@sp4rkr4t)
Estimable Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I've only just found out about the IFS update for the bondtech extruder, I have the older bondtech extruder on my mini, anyone know if it's possible to print the new parts to make it like the IFS update?

Posted : 11/01/2022 10:07 pm
fuchsr
(@fuchsr)
Famed Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

You can buy the upgrade kit ( https://www.bondtech.se/product/prusa-mini-extruder-upgrade-to-ifs/) but I haven't seen STLs for download, to print your own parts.

Public Service Announcement:  The upgrade kit will NOT work with the Trianglelab clone of the Bondtech extruder!!!

Posted : 11/01/2022 11:26 pm
Chris Laudermilk
(@chris-laudermilk)
Estimable Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

Well, I explicitly tested this yesterday. I had a couple of print jobs that I knew would run out the end of a spool, so I let it go. Sure enough, as soon as the filament end ran through the sensor, it triggered and paused the print. Parked the head and ejected the remainder of filament. Worked perfectly. This was with my software setup noted earlier (up-to-date firmware & OctoPi). Hardware is completely stock.

I looked at the Bondtech info and it appears you can update an older non-IFS one with the IFS update kit for $35. It looks like it swaps out the back plate with the one that has spaces for the Prusa sensor guts. Once I finally decide I need to make that upgrade, I'll go with the IFS version.

Mini+ (kit) - Revo Micro

Posted : 12/01/2022 3:30 pm
JJ
 JJ
(@jj-2)
Active Member
RE: MINI+ Filament Sensor doesn't detect out-of-filament?

I remember seeing that switch a few months ago - I don't remember how it got displayed. Unfortunately, I flipped the switch (I think it said use the internal sensor) and today I found that my sensor no longer worked when my filament ran out since I fiddled with that setting. It had worked originally. I then checked the menu and saw an NA for the sensor. So, somehow, you can disable the sensor permanently and not be able to recover. I'll try to reinstall the firmware and see if that does anything.

Posted : 22/09/2022 8:58 pm
Share: